您的位置  技术应用

Linux内核发现3个提权漏洞 已存在15年之久

  通常情况下,基于 Linux 的发行版本要比 Windows 更加安全,但这并不是说就没有漏洞了。 近日,网络安全公司 GRIMM 的安全研究人员在 Linux 内核中发现了不少于 3 个漏洞,可以利用这些漏洞可以获得系统的 root 权限。更重要的是,这些漏洞已经存在长达 15 年之久。

  这些漏洞(被追踪为 CVE-2021-27363、CVE-2021-27364 和 CVE-2021-27365)存在于内核的 iSCSI 模块中。虽然在默认情况下该模块是没有被加载的,但是 Linux 内核对模块按需加载的支持意味着它可以很容易地被调用到行动中。安全专家在 Red Hat 所有已测试版本和其他发行版本中均存在这些漏洞。

  在 GRIMM 博客上,安全研究员 Adam Nichols 表示:“我们在 Linux mainline 内核的一个被遗忘的角落里发现了 3 个BUG,这些 BUG 已经有 15 年的历史了。与我们发现的大多数积满灰尘的东西不同,这些 BUG 依然存在影响,其中一个原来可以作为本地权限升级(LPE)在多个 Linux 环境中使用”。

  这些漏洞存在于无法远程访问的代码中,所以无法被黑客远程利用。但这并不意味着它的破坏力不强。Nichols 警告说黑客可以利用这些漏洞发起任何现有的网络威胁,甚至于会让事情变得更加糟糕。可以想象在你的系统中有不信任的用户以 root 权限访问,这是多么的可怕。

  在详细介绍这三个漏洞的博文中,Nichols 解释了受影响的系统类型:

  为了让这些漏洞暴露在用户区,scsi_transport_iscsi 内核模块必须被加载。当执行创建 NETLINK_ISCSI 套接字的调用时,这个模块会被自动加载。此外,至少有一个 iSCSI 传输必须在 iSCSI 子系统中注册。在某些配置中,当无权限的用户创建 NETLINK_RDMA 套接字时,ib_iser 传输模块将被自动加载。

  正如 SC Media 所解释的那样,这些漏洞已经在以下内核版本中得到修复:5.11.4、5.10.21、5.4.103、4.19.179、4.14.224、4.9.260 和 4.4.260。而其他已经停止支持的内核将不会收到本次安全修复。

  【来源:cnBeta.COM】

免责声明:本站所有信息均搜集自互联网,并不代表本站观点,本站不对其真实合法性负责。如有信息侵犯了您的权益,请告知,本站将立刻处理。联系QQ:1640731186
  • 标签:治类风湿有什么好药
  • 编辑:晓松
  • 相关文章
网站推荐更多>>
热网推荐更多>>